Install RealPlayer

Download file RealPlayer10GOLD.bin di sini kemudian jalankan command berikut pada console:

chmod +x RealPlayer10GOLD.bin

sudo ./RealPlayer10GOLD.bin

Install Opera Browser

Jalankan perintah di bawah ini:

sudo apt-get install comix kopete gnochm dvdrip easytag kompozer \
             drapes subtitleeditor flashplugin-nonfree opera

Install RMagick

Ketika menjalankan

gem install rmagick

tampil error

checking for Magick-config... no
Can't install RMagick 2.5.0. Can't find Magick-config in [...]

yang harus dilakukan adalah install package libmagick9-dev

apt-get install libmagick9-dev

kemudian jalankan

gem install rmagick

Fix “uninitialized constant Gem::GemRunner (NameError)”

Jika tampil error

root@ditto:/home/ditto# gem list
/usr/bin/gem:23: uninitialized constant Gem::GemRunner (NameError)

Setelah googling sebentar, ketemu hasilnya di http://www.nickpeters.net/2007/12/31/fix-for-uninitialized-constant-gemgemrunner-nameerror/. Menurut yang tertulis di sana perlu dilakukan perubahan pada /usr/bin/gem tinggal menambahkan baris berikut :

require 'rubygems/gem_runner'

setelah baris

require 'rubygems'

Kemudian daftar gem sudah dapat dilihat seperti semula :

root@ditto:/home/ditto# gem list

*** LOCAL GEMS ***

actionmailer (2.0.2, 1.3.6, 1.3.3)
actionpack (2.0.2, 1.13.6, 1.13.3)
actionwebservice (1.2.6, 1.2.3)
activerecord (2.0.2, 1.15.6, 1.15.3)
activeresource (2.0.2)
activesupport (2.0.2, 1.4.4, 1.4.2)
archive-tar-external (1.2.1)
archive-tar-minitar (0.5.1)
builder (2.1.2)
capistrano (2.2.0)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10, 1.0.9)
fastthread (1.0.1)
gem_plugin (0.2.3)
highline (1.4.0)
hoe (1.5.0)
hpricot (0.6)
mini_magick (1.2.3)
mongrel (1.1.4, 1.1.3)
mongrel_cluster (1.0.5)
needle (1.3.0)
net-sftp (1.1.1)
net-ssh (1.1.2)
rails (1.2.6, 1.2.3)
rake (0.8.1)
rmagick (2.2.2)
rubyforge (0.4.4)
tzinfo (0.3.8)
xml-simple (1.0.11)

Temans,

Hari ini aku udah 3 hari pakai kubuntu. Setelah install ruby beserta paket2 pendukungnya, aku baru sadar kalau masih menggunakan rubygems versi 0.9.4. Akhirnya aku coba upgrade dengan “gem update –system“, hasilnya keluar error di konsole pas aku jalankan “gem” errornya kayak gini “/usr/bin/gem:23: uninitialized constant Gem::GemRunner (NameError)“. Nah setelah tanya-tanya ma om google, akhirnya ketemu deh jawabannya. Ringkasnya, buka “/usr/bin/gem” kemudian tambahkan “require ‘rubygems/gem_runner’” setelah script “require ‘rubygems’“. Setelah itu, jalankan “gem -v” maka akan muncul versi rubygem yang terbaru yang menandakan rubygem telah berhasil diupgrade. B-)